博客
关于我
强烈建议你试试无所不能的chatGPT,快点击我
Common Subsequence
阅读量:7210 次
发布时间:2019-06-29

本文共 1700 字,大约阅读时间需要 5 分钟。

 

 

 

Common Subsequence

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 32   Accepted Submission(s) : 16

Font: Times New Roman | Verdana | Georgia

Font Size: ← →

Problem Description

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, ..., xm> another sequence Z = <z1, z2, ..., zk> is a subsequence of X if there exists a strictly increasing sequence <i1, i2, ..., ik> of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.
The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.

Sample Input

abcfbc abfcabprogramming contest abcd mnp

Sample Output

420

Source

Southeastern Europe 2003

 

 

 

 

 

 

 

 

 

 

 

 

 

#include <iostream>

#include<string>
using namespace std;
char d[1000],p[1000];
int a[1000][1000];

int main()

{int i,j,d2,d1;
    while(cin>>d>>p)
    {d1=strlen(d);
    d2=strlen(p);
for(i=0;i<d1;i++)
for(j=0;j<d2;j++)
a[i][j]=0;
        for(i=1;i<strlen(d)+1;i++)
for(j=1;j<strlen(p)+1;j++)
{if(d[i-1]==p[j-1])
a[i][j]=a[i-1][j-1]+1;
else
a[i][j]=a[i-1][j]>a[i][j-1]?a[i-1][j]:a[i][j-1];

}

cout<<a[d1][d2]<<endl;

    }

    return 0;
}

转载于:https://www.cnblogs.com/lengxia/p/4387865.html

你可能感兴趣的文章
cdoj 1252 24点游戏 dfs
查看>>
JAVA中int、String的类型转换
查看>>
【iOS开发-74】解决方式:Xcode6下利用preference保存数据,终于的plist文件在哪里?...
查看>>
Linux下mysql备份 恢复
查看>>
iOS 开发-单元测试
查看>>
[TypeScript] Installing TypeScript and Running the TypeScript Compiler (tsc)
查看>>
使用.NET Framework的配置文件app.config
查看>>
C++11 并发指南------std::thread 详解
查看>>
windows下编译chromium浏览器的15个流程整理
查看>>
p2p穿透技术
查看>>
Coding 初级教程(二)——上传已有项目
查看>>
Esper epl语句实验
查看>>
【TensorFlow】CNN
查看>>
redis cli命令
查看>>
网上开店进货渠道大参考
查看>>
图灵成立七周年——经典回顾
查看>>
我曾经七次鄙视自己的灵魂 卡里.纪伯伦
查看>>
Oracle 默认表空间(default permanent tablespace) 说明
查看>>
Dapper的语法应用
查看>>
Effective C++ 条款44
查看>>